Announcement

Collapse
No announcement yet.

MECHA - Bug Report

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi Dorin,

    that last setup you described seems to be very useful.
    I think I have done al the steps right but despite the fact the LEDs show the Mechas should be paired the UI doesen't show the "H" or "V" in the uper left corner.
    What I am doing wrong?
    FW is the latest 02062
    Here are the screenshots of both Mechas (row tab as well as config tab)

    But I'm just testing my recently developed working s-language script and it is working fine, controlling both mechas as meant by the script.

    kind regards
    Frank

    Click image for larger version  Name:	V-Mecha-config.png Views:	1 Size:	84.4 KB ID:	31543
    Attached Files
    Last edited by FrankD; March 10, 2020, 09:34 AM.

    Comment


    • Is OK, [H] and [V] appear only when the MECHA are automatically paired at start.

      With this last setup, you need to pair them with manually after start like with the codes 1212< and 12<
      [H] will no appear but you can give MECHA-H-DAC name or similar, same for MECHA-V to see which is which.

      I'll add [H] and [V] to be shown in all the cases..when I'll have a little time for that.

      if LEDs lit - = and test work is OK, is fine,
      also [Team] button in H MECHA UI will look like

      [Team .102]
      that is also a sign of pairing.

      the address terminated in .101 is always for H MECHA and .102 is for V MECHA in the example I gave.

      When you don't use UI, short press on power button will lit LEDs 10 seconds later,
      but don't press when MECHA is doing a pano as the Power button acts like emergency stop,
      unless you want to stop, of course.





      1. Mecha it possible.
      2. Mecha it easy.
      3. Mecha team up.

      4. ..

      Comment


      • Originally posted by DorinDXN View Post
        Is OK, [H] and [V] appear only when the MECHA are automatically paired at start.

        I'll add [H] and [V] to be shown in all the cases..when I'll have a little time for that.
        Thank you,

        it's not that big of an issue to me not having the H and V visible as long as it is working.

        With this setup I have the advantage not only to be paired but also have internet connection if my phone and I somewhere with a reasonable net supply.

        Kind regards
        Frank
        Last edited by FrankD; March 10, 2020, 10:54 AM.

        Comment


        • Originally posted by DorinDXN View Post
          Is OK, [H] and [V] appear only when the MECHA are automatically paired at start.

          With this last setup, you need to pair them with manually after start like with the codes 1212< and 12<
          [H] will no appear but you can give MECHA-H-DAC name or similar, same for MECHA-V to see which is which.
          Starting with C1E_02066 is no need to manual pair with 1212< and 12< anymore

          The pairing will be automatically established after power up if the SSID NAME of MECHAs starts with MECHA-H and MECHA-V respectively
          if they are both connected to the same network. i.e. MECHA-PHONE hot-spot in this case.

          1. Mecha it possible.
          2. Mecha it easy.
          3. Mecha team up.

          4. ..

          Comment


          • Cool,👍

            that is the most convenient setup for me.

            Frank

            Comment


            • Hi Dorin,

              In DAC, The operation when the "1 x LEFT" or "1 X RIGHT" button is pressed with the sequence interrupted once is abnormal.
              It will help if this works correctly with DAC as "1 x FORWARD" or "1 x BACK".

              Comment


              • We have MECHAs connected to a SSID with Internet access, provided 3g, 4g so on..
                the pairing is not automatically established after power up but
                can be started with
                1212< on H MECHA
                then confirmed with
                12< on V MECHA,
                So, both connected to phone AP, but they discover each other and communicate through the network when recognized through 1212 and 12?
                Interesting!
                Luca Vascon.

                officinepanottiche.com
                -- o --
                I Void Warranties!

                Comment


                • Originally posted by DorinDXN View Post

                  Starting with C1E_02066 is no need to manual pair with 1212< and 12< anymore

                  The pairing will be automatically established after power up if the SSID NAME of MECHAs starts with MECHA-H and MECHA-V respectively
                  if they are both connected to the same network. i.e. MECHA-PHONE hot-spot in this case.
                  this is wonderful.
                  Luca Vascon.

                  officinepanottiche.com
                  -- o --
                  I Void Warranties!

                  Comment


                  • When inputting the Field E:1/8*5 sec does not work it must be inputted as E:0.125*5 sec. this more of an FYI than a request for fix

                    Comment


                    • Thanks for reporting, indeed is something not right there.
                      I'll fix and publish a FW update today.
                      1. Mecha it possible.
                      2. Mecha it easy.
                      3. Mecha team up.

                      4. ..

                      Comment


                      • Hi Dorin

                        There seems to be a small problem with preset programming.
                        When "192.168.8.1/preset?b=1&s=4" is entered
                        It works normally with LEFT or RIGHT button of UI.
                        However, if you enter “1 <” in MECHA, it rotates 30 degrees and shoots 4 times.
                        The rotation angle seems to be fixed at 30 degrees.
                        Please check.

                        Comment


                        • I'm looking on it, thanks for reporting, will be a fix ASAP
                          1. Mecha it possible.
                          2. Mecha it easy.
                          3. Mecha team up.

                          4. ..

                          Comment


                          • Is fixed in C1E_02136,
                            is need to execute the command

                            "192.168.8.1/preset?b=1&s=4"

                            again

                            ----------------------------------------8<-------------------------------------

                            C1E_02136
                            Addressed an issue regarding the programming of a preset using parameters,
                            with the s= parameter given,
                            produced 30 deg. interval instead of the required one
                            when the preset was executed using the buttons and not from UI.
                            1. Mecha it possible.
                            2. Mecha it easy.
                            3. Mecha team up.

                            4. ..

                            Comment

                            Working...
                            X