Announcement

Collapse
No announcement yet.

Accessing C2 UI with Android Smartphone fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Accessing C2 UI with Android Smartphone fails

    I just received my Mecha E2 C2 and I´m trying to connect my Samsung S10 (Android 12) with my C2 controller, accessing the C2 UI.
    The WiFi connection works and stays stable. When trying to connect with the 192.168.8.1 IP address, connection is refused. It makes no difference trying Firefox, Chrome or the Samsung browser.
    I tried to figure out in the browser settings if the IP address might be blocked, but couldn´t find any options to allow access. I also checked my Avira internet security SW, but couldn´t find any hint, that the IP address is blocked by this.
    What´s going wrong, user fault, technical issue?

    Thanks for any helpful advice.

    Btw, the firmare update did work without any problem.

    Kind regards
    Winfried

    P.S.: Connection is rejected in AP as well as AP+STA mode.
    Last edited by Winfried; September 20, 2022, 08:01 AM.

  • #2
    If you just received MECHA, I suppose there are no presets made to be backed-up.

    please try a factory reset
    is in C 85 Menu on OLED,
    you need to select the option twice,

    let me know if you need more help, either here or via e-mail
    1. Mecha it possible.
    2. Mecha it easy.

    MECHA Support mecha(at)nodalninja.com

    Comment


    • #3
      Thanks for your advice. Running the reset did make the connection with my phone working.
      Same connection issue now occurs when trying to connect to my notebook.
      I did set the WiFi access data of my home router in the config menue when connected to my phone. When selecting the SSID 4 different SSIDs of my router are listed for selection. My router does support 2.4 GHz and 5GHz.
      I just selected the top one, did enter login data, but the connection timed out on my WIN11 notebook (Mecha WiFi hotspot was disconnected from my phone).

      Do I have to run the reset again to get the connection to my router working?
      Could it be the case that 5GHz SSID was selected at setup?

      Comment


      • #4
        MECHA supports only 2.4 GHz,
        the available SSIDs should be listed when accessing
        192.168.8.1/connect
        is no need to run reset again.

        after connected to router, MECHA can be accessed if is in either STA or AP+STA or after select the
        CONNECT TO Wi-Fi
        option from the OLED Menu at C 42
        the i.p. given by router should be visible if you press the power button of C2


        1. Mecha it possible.
        2. Mecha it easy.

        MECHA Support mecha(at)nodalninja.com

        Comment


        • #5
          As Mecha supports 2.4 GHz only, it should not be possible to connect with 5 GHz band, respective 5 GHz should not be listed during setup, correct?
          When pressing the power button a router IP address is visible but connection is not listed in routers active WiFi connection overview, connection with 192.168.1.100 still times out in notebook browser.
          How to reset the WiFi connection, I´d like to redo the WiFi pairing.
          Last edited by Winfried; September 20, 2022, 01:20 PM.

          Comment


          • #6
            That is correct,
            192.168.8.1/connect
            will show the 2.4 GHz SSIDs only

            to reset Wi-Fi
            when MECHA is powering ON
            when - + = is visible on OLED, press and hold [=] until multiple beeps are heard

            1. Mecha it possible.
            2. Mecha it easy.

            MECHA Support mecha(at)nodalninja.com

            Comment


            • #7
              The reset did work. After reconnecting to my home WiFi, Mecha connected to my router but my browser didn´t connect to 192.168.1.100.
              I did check on C2 display and it did show the same IP as yesterday. in next step I did check the network connections in my router and did find C2 connected via a Mesh repeater in my wireless network. after klicking on the device UI immediately opened in firefox mapped to the IP adresse given by the router.
              I´m puzzelled about this since the manual shares 192.168.1.100 as connection IP??
              I´ve bookmarked the IP address and reconnection is working using the bookmark.

              Comment


              • #8
                Can you open any of these pages from your notebook?















                Last edited by DorinDXN; September 21, 2022, 04:13 AM.
                1. Mecha it possible.
                2. Mecha it easy.

                MECHA Support mecha(at)nodalninja.com

                Comment


                • #9
                  None of them is working.

                  Comment


                  • #10
                    To remove Win11/Notebook from equation, you can try to connect the notebook directly to MECHA's SSID

                    then try to access, say
                    192.168.8.1/c2
                    from notebook.

                    if that works, then you can focus on the router/mesh repeater settings.
                    Last edited by DorinDXN; September 21, 2022, 05:53 AM.
                    1. Mecha it possible.
                    2. Mecha it easy.

                    MECHA Support mecha(at)nodalninja.com

                    Comment


                    • #11
                      This connection works, as it works with my Samsung phone.
                      I´ll check my Wifi settings now try to find out what´s causing the problem.
                      Anyhow as workaround I can connect C2 via the assigned network IP adress. This connection works and I´ve done some tests modifying the supplied presetsand operate the Mecha accordingly.
                      Thanks for your great support, highly appreciated.

                      Comment

                      Working...
                      X